Slave Vs Fuel outputs

Post Reply
MikeyB571
Posts: 40
Joined: Sat Nov 26, 2011 12:05 pm

Slave Vs Fuel outputs

Post by MikeyB571 » Fri Jul 12, 2019 12:30 pm

I have been struggling to control the VVT solenoids well on my 2GR-FE engine.
They have been hooked up to fuel outputs, and I managed to find a PWM frequency that gave the most stable movement (240Hz) but the dynamic range was only between 70 and 90 % duty (So it only moved the solenoid between 70 and 90%).

I’ve been working with it in this way but then thought I’d see whether I should try using H-Bridge mode with one of the slave outputs on my S6 Plus. Well, I started by simply using the Slave output in the same way as before (Low Side Mode) and it works really well. Perfectly in fact, at the same frequency.

I’ve got plenty of outputs spare, so I plan to move over to using the slave outputs but can anyone explain why this is?
Is it power limitation on the fuel outputs perhaps and I’m saturating them?

Thanks in advance.

Michael.

TimH
JT Innovations
Posts: 605
Joined: Wed Sep 01, 2010 2:51 pm

Re: Slave Vs Fuel outputs

Post by TimH » Fri Jul 12, 2019 1:42 pm

Probably lack of flyback (catch) diodes when you used the injector drivers - the back emf does cause havoc with the duty otherwise.

The S6+ H-bridge outputs use different drivers and either have diodes, or the nature of the half-bridge drivers is such that they cope with inductive loads better.

MikeyB571
Posts: 40
Joined: Sat Nov 26, 2011 12:05 pm

Re: Slave Vs Fuel outputs

Post by MikeyB571 » Fri Jul 12, 2019 3:47 pm

That makes sense, might be worth experimenting with adding a flyback diode to the fuel output to see if it then works better.

Post Reply