Page 1 of 1

pin outputs should they have any voltage on them

Posted: Tue Jun 02, 2020 5:52 pm
by firepete
x10 outputs should there be any voltage on them with the ignition on . im finding im getting 6v to earth. what would cause this .
i was under impression it was a ground return to operate via ecu

Re: pin outputs should they have any voltage on them

Posted: Tue Jun 02, 2020 9:36 pm
by stevieturbo
I havent measured mine, but in general a lot of ecu related stuff can show approx 12v ( or nominal batt voltage ) on OFF outputs.

Simple because when OFF, they do not physically break the circuit like a switch, so when resting at 12v, there is no potential difference in the circuit, hence it is OFF

And when it's in an ON state, it will pull to ground creating a complete circuit.

Re: pin outputs should they have any voltage on them

Posted: Sat Jun 06, 2020 9:53 am
by firepete
i have checked al my inputs and outputs and they all show 6v to earth .on the x10 .but not on the ecu .

im trying to find a fault why my exhaust vvt does not work . the inlet solenoid is operated from ecu but exhaust had to come off the x10
it has worked in the past but failed a few times so had it disabled . but believe that was now a a faulty 12v supply in the early days .
the cam sensors are both off the ecu .
is there any way of testing the circuits .with out round engine . apart from buzzing out the wiring .

Re: pin outputs should they have any voltage on them

Posted: Sat Jun 06, 2020 11:13 am
by stevieturbo
Testing...that does relate to something I mentioned recently.

I can find no way of manually activating the X10 outputs for a proper test.

However, you could configure the output as something like a fan, and manipulate the output to come off or on that way. ( easy way would be set a sensor default value of 100deg or higher than fan turn on and just unplug the ECT sensor which should then trigger than "fan" or output )
Or just set the off/on temp higher or lower than the current temperature so it would activate or stop as required.

and use say a test lamp or buzzer connected at the solenoid or actuator to verify if it does go off and on as expected.

Re: pin outputs should they have any voltage on them

Posted: Sat Jun 13, 2020 7:15 pm
by firepete
cheers